Exchange 2013. IMAP (S) not Connectable. No peer certificate available

You are find IMAPS connections aren’t working. You’ve checked the settings with Get-IMAPSettings and confirmed the services are running.

Testing with OpenSSL you find there are problems with the SSL Handshake

openssl s_client -showcerts -connect %ServerName%:993
Loading ‘screen’ into random state – done
CONNECTED(00000634)
write:errno=10054

no peer certificate available

No client certificate CA names sent

SSL handshake has read 0 bytes and written 317 bytes

New, (NONE), Cipher is (NONE)
Secure Renegotiation IS NOT supported
Compression: NONE
Expansion: NONE
No ALPN negotiated

It took me a while to find this. It looks like Active Manager has intervened and disabled the Imap component.

Get-ComponentState -Identity ExchangeServer

And what do we see?

Component State
——— —–
ImapProxy Inactive

This kind of makes sense, just think about what you do to the Hub Transport component when you patch servers in a DAG.

This can be fixed by running

Set-ServerComponentState -Identity ExchangeServer1 -Component imapproxy -State Active -Requester HealthApi

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s